Информатика, вопрос задал iljakononov2003 , 2 года назад

СРОЧНОООО

Составить программу обработки списка (массива) М, состоящего из 10 элементов. Все элементы массива М, значения которых находятся в интервале от -5 до 10 возвести в квадрат. Измененный массив вывести на экран.
ПРОШУ СРОЧНО


iljakononov2003: язык пиоон
Plus9ToIntellect: щас
iljakononov2003: сроочно пж 5 мин осталось)
Plus9ToIntellect: Всё, есть
Plus9ToIntellect: Защиты от "дурака" не предусмотрено
iljakononov2003: я не шарю
iljakononov2003: как сделать чтобы все сразу работало\тупо скопировать
Plus9ToIntellect: Ты хочешь сказать, что не умеешь запускать???
iljakononov2003: я запустил
iljakononov2003: но не работает

Ответы на вопрос

Ответил Plus9ToIntellect
1

arr = [int(i) for i in input().split()]

new_arr = []

for i in arr:

  if i>=-5 and i<=10:

       new_arr.append(i**2)

   else:

        new_arr.append(i)

[print(i, end=" ") for i in new_arr]

Краткий гайд:

  • arr -  исходный список
  • new_arr - измененный список
Приложения:

Plus9ToIntellect: ну почему не реализовать поддержку html тегов, >code< например
Plus9ToIntellect: Упс, угловые скобки перепутал
Plus9ToIntellect: Это поможет, я думаю.
Plus9ToIntellect: Остаётся ещё вопрос, почему на этом сайте можно нормально находится только под VPN-ом(Я нахожусь в Беларуси)
KnowsUser1: Подсветку кода ещё вряд ли будет кто либо делать потому, что программирование - это лишь небольшой раздел в одном предмете, и по отношению к остальным вопросам, его тут почти нет. И как бы, ради чего возиться?
Новые вопросы