Информатика, вопрос задал warframed981 , 7 лет назад

Срочнооо ребят!!! Напишите программу, которая в последовательности целых чисел определяет количество отрицательных чисел и сумму положительных. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: количество отрицательных чисел и сумму положительных.

Ответы на вопрос

Ответил unnamedhostname2
0

# Python 3.x

# sequence - данная нам последовательность чисел

odds=int()

sumary=int()

for digit in sequence:

   if digit == 0: break

   if digit % 2 == 0: sumary=sumary + digit

   else: odds=odds + 1

print("Sumary: ", sumary)

print("Odds amount: ", odds)

Новые вопросы