Информатика, вопрос задал mangoGirl777 , 8 лет назад

СРОЧНООО , ПОМОГИИИТЕ((((
Ниже записана программа. Получив на вход число , эта программа печатает два числа, L и M .Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
if x mod 2 = 0 then
M:= M + x mod 10;
x:= x div 10;
end;
writeln(L); write(M);
end

На этот вопрос еще никто не ответил. Напишите свой ответ или воспользуйтесь поиском:

Новые вопросы