СРОЧНОО!!!
Составить программу заполнения массива случайными числами в диапазоне -30 до 30 и определяет количество чётных элементов массива.
Ответы на вопрос
Ответ:
//Составить программу заполнения массива случайными числами в диапазоне -30 до 30 и определяет количество чётных элементов массива.
program massiv;
const N=20;
var m:array[1..n] of integer;// поставил 20 элементов массива
i:byte;
count:integer;
BEGIN
//заполнение случайными числа в диапазоне [-30;30]
//random(61) выдает случ. значение от 0 до 60, если вычесть -30 с концов этого отрезка получится от -30 до 30
for i:=1 to n do m[i]:=random(61)-30;
//вывод полученного массива на экран
writeln('Полученный массив');
for i:=1 to n do write(m[i],' ');
writeln;//переход на следующую строку
//сортировка пузырковым методом
for i:=1 to n do
if (m[i] mod 2=0) then count:=count+1;
writeln('Кол-во четных элементов = ', count);
END.
Объяснение: