СРОЧНО11! 50 баллов
Напишите программу, которая в последовательности натуральных чисел
определяет произведение чисел оканчивающихся на 5.Паскаль. Цикл for
avion321321:
какой язык?
Ответы на вопрос
Ответил avion321321
0
Ответ:
var
a: array [1..10000] of integer;
N: integer;
i: integer;
Product: integer;
begin
product := 1;
write('Введите количество элементов в массиве: ');
readln(N);
write('Введите элементы массива: ');
for i:=1 to N do
begin
read(a[i]);
if (a[i] mod 10 = 5) then
begin
product := product * a[i];
end;
end;
write('Произведение элементов: ', product);
end.
Ответил wensent
0
Ответ:
Program p1;
Var a, i, n, k: integer;
Begin
Write('Введите количество чисел последовательности: ');
readln(n);
k:=1;
For i:=1 to n do begin
readln (a);
if (a mod 10 =5) then k:=k*a;
end;
Writeln('Произведение чисел оканчивающихся на 5 - ',k);
End.
Новые вопросы