Информатика, вопрос задал sladkaakonfetka19 , 6 лет назад

СРОЧНО!!!
ЗАРАНЕЕ БЛАГОДАРЮ!! НА PYTHON!!
Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Пример:

Введите N:
1000
1*1=1
5*5=25
6*6=36
25*25=625
76*76=5776

Ответы на вопрос

Ответил daniyarkanu
3

Решение:

Python

N = int(input())

k = 0

for i in range(1, N + 1):

   k = k + 1

   k_str = str(k)

   k_len = len(k_str)

   i_i = i ** 2

   i_i_str = str(i_i)

   if i_i_str[-k_len:] == k_str:

       print(k_str, '*', k_str, '=', i_i_str)

У тебя в примере вывода для 1000 не дописаны 376 и 625 хотя они входят в диапозон 1000. Если в int(input()) ввести 1000 выведет:

1 * 1 = 1

5 * 5 = 25

6 * 6 = 36

25 * 25 = 625

76 * 76 = 5776

376 * 376 = 141376

625 * 625 = 390625

Новые вопросы