Срочно!!!
В Паскале
Составить программу для ввода с клавиатуры 7 целых чисел.
Вывести на экран: 1) элементы массива с положительными значениями.
2)элементы массива с нечетными значениями
3)элементы массива, значения которых положительны и кратны 5
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1541 от 29.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Введите 7 целых чисел:',7);
Write('Положительные: '); a.Where(x->x>0).Println;
Write(' Нечетные: '); a.Where(x->x.IsOdd).Println;
Write('Положительные, кратные 5: '); a.Where(x->(x>0) and (x mod 5=0)).Println
end.
Пример
Введите 7 целых чисел: -5 6 21 15 -20 40 0
Положительные: 6 21 15 40
Нечетные: -5 21 15
Положительные, кратные 5: 15 40
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Введите 7 целых чисел:',7);
Write('Положительные: '); a.Where(x->x>0).Println;
Write(' Нечетные: '); a.Where(x->x.IsOdd).Println;
Write('Положительные, кратные 5: '); a.Where(x->(x>0) and (x mod 5=0)).Println
end.
Пример
Введите 7 целых чисел: -5 6 21 15 -20 40 0
Положительные: 6 21 15 40
Нечетные: -5 21 15
Положительные, кратные 5: 15 40
Новые вопросы
Математика,
2 года назад
Українська література,
2 года назад
Геометрия,
8 лет назад
Алгебра,
8 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад