Информатика, вопрос задал stef2365 , 7 лет назад

Срочно!!! Третья пересдача, помогите написать программу для этой задачи, пожалуйста! Язык C++

Задан числовой массив А[m][n]. Составить программу поиска элемента массива, который является наибольшим из минимальных по строкам​

Ответы на вопрос

Ответил xyligan23
0

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

#include <iostream>

int main(){

   setlocale(0, "rus");

   const int m = 3, n = 4;

   int i, j, k, max, A[m][n];

   for (i = 0; i < m; i++)

   for (j = 0; j < n; j++)

       std::cin >> A[i][j];

   for (i = 0; i < m; i++)

   {

       max = 0;

       for (j = 1; j < n; j++)

       if (A[i][j]>A[i][max])

           max = j;

       for (k = 0; k < m; k++)

       {

           if (A[k][max]>=A[i][max])

               break;

           std::cout << i+1 << ";" << max+1 << "n";

           return 0;

       }

   }

   std::cout << "0n";

   return 0;

}

Ну на хз правильно или нет так как из 8 класса,но все равно

Новые вопросы