срочно! создать программу!
тема "организация подпрограмм через функцию"
задача
дан параллепипед с измерениями а,b, c. Составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.
Ответы на вопрос
Ответил Аноним
0
Вычисление производим по формуле

function Sp(x,y:real):real;
begin
Sp:=x*y
end;
var
a,b,c,S:real;
begin
Write('Введите размеры сторон a,b,c: ');
Read(a,b,c);
S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
Writeln('Площадь поверхности равна ',S)
end.
Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95
function Sp(x,y:real):real;
begin
Sp:=x*y
end;
var
a,b,c,S:real;
begin
Write('Введите размеры сторон a,b,c: ');
Read(a,b,c);
S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
Writeln('Площадь поверхности равна ',S)
end.
Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
История,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад