Информатика, вопрос задал AriTmir , 7 лет назад

СРОЧНО!!! Составьте программу на Паскаль, которая, введенное с клавиатуры число, возведёт в куб, если оно положительное, если отрицательное найдет его модуль, а если оно будет равно 0, то прибавить к нему 10.

Ответы на вопрос

Ответил byaka0
0

Ответ:

var x, result: integer;

begin

 readln(x);

 if (x > 0) then

   result := sqr(x)*x

 else if (x < 0) then

   result := abs(x)

 else if (x = 0) then

   result := x + 10;

 writeln(result);

end.

Новые вопросы
Алгебра, 7 лет назад