Информатика, вопрос задал nioba777 , 7 лет назад

Срочно!!! Составить программу, которая сортирует четыре числа по порядку возрастания и убыванию. Несколько вариантов, пожалуйста. Через if... Then

Ответы на вопрос

Ответил iaroslavshahnazarov
0

Ответ:

вот программа сортирующая n чисел  

uses crt;  

const nmax=100;  

var a:array[1..nmax] of real;  

n,i,j:integer;  

x:real;  

begin  

clrscr;  

randomize;  

repeat  

write('n=');  

readln(n);  

until n in [1..nmax];  

writeln('Исходный массив: ');  

for i:=1 to n do  

begin  

a:=10*random;  

write(a:5:2);  

end;  

writeln;  

for i:=1 to n-1 do  

for j:=i+1 to n do  

if a<a[j]>;  

a:=a[j];  

a[j]:=x;  

end;  

writeln('Сортировка: ');  

for i:=1 to n do  

write(a:5:2);  

readln  

end.

Объяснение:

Ответил l1TaCh1l
0
ето в какой проге
Новые вопросы