Срочно! Составить программу!!!
Количество чисел задается пользователем:
чтобы найти среднее арифметическое надо:
1. запросить у пользователя сколько вводится чисел(N)
2. сравнить количество чисел с нулем
2.1 если количество чисел >0 (т. к. количество чисел должно быть натуральным), то:
2.1.1 т. к. мы будем находить сумму чисел, значит начальное значение следует приравнять 0
2.1.2 выполнять цикл мы будем N раз. В цикле мы должны:
2.1.2.1 запросить число(А)
2.1.2.2 к полученной сумме прибавить введенное число
2.1.3 найти среднее арифметическое введенных чисел
2.1.4 вывести полученное значение
2.2 если количество чисел <=0 то:
2.2.1 вывести сообщение об ошибке.
Ответы на вопрос
Ответил DmitryINF
0
var
a,sum,i,n:integer;
begin
readln(n);
if n<=0 then
writeln('N не натуральное число')
else
begin
sum:=0;
for i:=1 to n do
begin
read(a);
sum:=sum+a;
end;
writeln(sum/n);
end;
end.
a,sum,i,n:integer;
begin
readln(n);
if n<=0 then
writeln('N не натуральное число')
else
begin
sum:=0;
for i:=1 to n do
begin
read(a);
sum:=sum+a;
end;
writeln(sum/n);
end;
end.
Ответил DmitryINF
0
Как в алгоритме^_^
Новые вопросы