срочно с++
Циклический сдвиг
Напишите программу, которая будет циклически сдвигать заданный массив на один элемент вправо, последний элемент при этом должен оказаться на первом месте.
Входные данные
На вход программе сначала подается значение n≤100 — количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива — натуральные числа, не превосходящие 100.
Выходные данные
Выдайте значения элементов массива после выполнения указанной операции.
Примеры
Ввод
Вывод
5
8 7 4 8 3
3 8 7 4 8
Ответы на вопрос
Ответил omazda18
12
Ответ:
Объяснение:
#include <iostream>
#include <vector>
#include <algorithm>
#include <iterator>
using namespace std;
int main()
{
int n, a, k, b, i;
cin >> n;
vector<int> v(n);// создаём вектор из n чисел
for (int i = 0; i < n; ++i){
cin >> v[i];
}
cout << v[n - 1];
for(int i = 0; i < n - 1; ++i){
cout << ' ' << v[i];
}
}
Приложения:

Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Английский язык,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад