Срочно пж! Нужно написать программу на c++
15. Дан одномерный массив, состоящий из N вещественных элементов.
15.1. Ввести массив с клавиатуры.
15.2. Найти минимальный положительный элемент.
15.3. Вычислить сумму четных элементов массива.
15.4. Вывести массив на экран в обратном порядке.
Ответы на вопрос
Ответил pz4t9v0d4tly
2
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
vector<int> arr;
int size, min(9999999), sum(0);
cout << "N: ";
cin >> size;
for (int i = 0; i < size; ++i) {
int temp;
cout << "Element #" << i + 1 << ": ";
cin >> temp;
arr.push_back(temp);
if (temp >= 0 && temp < min) {
min = temp;
}
if ((i + 1) % 2 == 0) { // нумеруем элементы с 1
sum += temp;
}
}
cout << "Min: " << min << endl;
cout << "Sum: " << sum << endl;
for (int i = arr.size()-1; i>=0; --i) {
cout << arr[i] << " ";
}
}
Приложения:

Новые вопросы
Русский язык,
2 года назад
Другие предметы,
2 года назад
Математика,
2 года назад
География,
2 года назад
Математика,
8 лет назад