СРОЧНО ПЖ
3.Напишите программу, которая принимает на вход натуральное число и проверяет является ли оно кратным 7?
olegkrasnov98:
язык?
Ответы на вопрос
Ответил mies
1
Ответ:
Язык программирования не был указан в условии, поэтому выбирайте:
Объяснение:
1) Python
print('Hе кратно') if int(input('Введите число: ')) % 7 else print('Kратно')
2) Pascal
program Number;
var number: integer;
begin
writeln ('Введите число: ');
readln(number);
if number mod 7 = 0 then
writeln('Kратно')
else
writeln('Hе кратно');
end.
3) C++
#include <iostream>
using namespace std;
int main()
{
int number;
cout <<"Введите число: " << endl;
cin >> number;
if (number % 7) {
cout << "Hе кратно";
} else {
cout << "Kратно";
}
return 0;
}
Ответил olegkrasnov98
1
n = int(input())
if n%7 == 0:
print(f"Число {n} кратно 7")
else:
print(f"Число {n} не кратно 7")
Новые вопросы