Информатика, вопрос задал maripshenova , 2 года назад

СРОЧНО!!!! Python!!
Распределите пробелы
Дана строка, содержащая по крайней мере один не ведущий пробел, за которым следует отличный от пробела символ. За счет изменения групп пробелов внутри строк (количества пробелов между словами) добиться того, чтобы в начале и в конце каждой из строк пробелы отсутствовали. Количество пробелов в разных группах внутри одной строки должно различаться не более чем на единицу. Количество символов в строке должно остаться неизменным.

Входные данные

На вход программе подается строка, состоящая не более чем из 255 символов.

Выходные данные

Выведите преобразованную строку. Если количество пробелов между словами отличается, то сначала должны идти группы пробелов минимального размера, а затем — на единицу большего размера.
Ввод:
ABCD XYZ QWE
Вывод:
ABCD XYZ QWE

Ответы на вопрос

Ответил Imilka007
1

text = input("Введите предложение: ").split() # Вводим и разделяем на части предложение с помощью split(). ["ABCD", "XYZ", "QWE"]

en = ""

for i in text:

   en += " "+i # С помощью цикла собираем предложение оставляя пробел в начале

print(en.strip()) # Убираем пробел в начале с помощью strip()

Новые вопросы