СРОЧНО!!! ПРОГРАММА С ВЕТВЛЕНИЕМ!!! Составьте программу, которая по введенному вами k-число грибов, печатает фразу: "Мы нашли в лесу k грибов" причем согласовывает окончание слова «гриб» с k.!!!
Ответы на вопрос
var k:integer;
begin
writeln('Input number of mushrooms: ');
Readln(k);
if k=1 then Writeln('Mi nashli ',k,' grib')
else
if (k=2) or (k=3) or (k=4) then Writeln('Mi nashli ',k,' griba')
else
Writeln('Mi nashli ',k,' gribov');
readln;
end.
var
count:integer;
begin
write('Введите количество грибов '); readln(count);
write('Мы нашли в лесу ', count);
case count div 10 of
1: writeln(' грибов');
else
case count mod 10 of
0, 5..9: writeln(' грибов');
1: writeln(' гриб');
2..4: writeln(' гриба');
end;
end;
end.