Срочно!!!
Программа для C, не для C++
Задача №112149. Расстояние
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.
Входные данные
В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа.
Выходные данные
Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.
Ответы на вопрос
Ответил VitalikMaksymchuk
2
#include <stdio.h>
#include <math.h>
int main()
{
double x1, x2;
double y1, y2;
printf("Введіть координати точок:\n");
scanf("%lf%lf%lf%lf, &x1, &x2, &y1, &y2);
double result = sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
printf("%.3lf\n", result)
return 0;
}
Новые вопросы
Английский язык,
2 года назад
Окружающий мир,
2 года назад
География,
2 года назад
Алгебра,
2 года назад
История,
8 лет назад