Информатика, вопрос задал Nadya1001 , 7 лет назад

СРОЧНО!!!! ПОЖАЛУЙСТА ПОМОГИТЕ!!
1. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. Программа должна вывести одно число — сумму чисел, кратных 3.

Вх. 3, 5, 15, 12

Вых. 27

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 5 и четное. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Вх. 4, 15, 20, 23, 30

Вых. 20

3. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 6.

Вх. 4, 36, 20, 216, 0

Вых. 252

Ответы на вопрос

Ответил moc05
3

Ответ:

1)

Program z1;

var i,n,a,sum:integer;

begin

readln(n);

for i:=1 to n do begin

 read(a);

 if(a mod 3 = 0) then sum:=sum+a;

 end;

writeln(sum);

end.

2)

Program z2;

var a,i,min,n:integer;

begin

min:=100000;

readln(n);

for i:=1 to n do begin

 read(a);

 if(a mod 5 = 0) and (a mod 2 = 0) and (a < min) then min:=a;

 end;

writeln(min);

end.

3)

Program z3;

var a,sum:integer;

begin

a:=1;

while a<>0 do begin

 read(a);

 if(a mod 6 = 0) and (a mod 10 = 6) then sum:=sum+a;

 end;

writeln(sum);

end.

Новые вопросы