Информатика, вопрос задал St546 , 1 год назад

СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА!
Составить программу для решения следующей задачи: Известный пират Флинт положил некоторую сумму S в банк под 4% годовых. Выведите на экран, через сколько лет сумма превысит 2S. Начальное значение S вводится с клавиатуры.

Ответы на вопрос

Ответил walfo2018
1

Відповідь:Program n_1;

var s, m: real; n:integer;

begin

 read(s);

 n:=0; m:=s;

 while (m<=1.5*s) do begin

  m:=m*1.03;

  n:=n+1;

 end;

 writeln(n);

end.

Честно говоря, решение тут вообще не зависит от S. Всегда выводится одно и то же число - 14

Пояснення:

Новые вопросы