Информатика, вопрос задал hakizzzer , 1 год назад

СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА, ПРОГРАМИРОВАНИЕ ПАСКАЛь
Помогите пожалуйста решить задачу. Объясните максимально для тупых.
Составить программу обработки массива В, состоящего из 20 элементов. Заполнить массив случайными числами в диапазоне от -10 до 15. Все элементы массива В возвести в куб. Измененный массив вывести на экран.

Ответы на вопрос

Ответил daniil062
0

program ProcessArray;

const

 N = 20;

 minVal = -10;

 maxVal = 15;

type

 IntArray = array [1..N] of integer;

var

 B: IntArray;

 i: integer;

{ Заполнение массива случайными числами в диапазоне от minVal до maxVal }

procedure FillArray(var A: IntArray; minVal, maxVal: integer);

var

 i: integer;

begin

 Randomize;

 for i := 1 to N do

   A[i] := Random(maxVal - minVal + 1) + minVal;

end;

{ Возведение каждого элемента массива в куб }

procedure CubeArray(var A: IntArray);

var

 i: integer;

begin

 for i := 1 to N do

   A[i] := A[i] * A[i] * A[i];

end;

{ Вывод массива на экран }

procedure PrintArray(const A: IntArray);

var

 i: integer;

begin

 for i := 1 to N do

   Write(A[i], ' ');

end;

begin

 FillArray(B, minVal, maxVal);

 CubeArray(B);

 PrintArray(B);

end.

В этой программе используются три процедуры:

  1. FillArray заполняет массив случайными числами в диапазоне от minVal до maxVal.
  2. CubeArray возводит каждый элемент массива в куб.
  3. PrintArray выводит массив на экран.

В основной части программы сначала вызывается процедура FillArray для заполнения массива B. Затем вызывается процедура CubeArray для возведения каждого элемента массива B в куб. Наконец, вызывается процедура PrintArray для вывода измененного массива на экран.


hakizzzer: Подскажи пожалуйста, как будет выглядит эта запись если вместо куба на квадрат умножать. PLSSS
hakizzzer: Подскажи пожалуйста, как будет выглядит эта запись, если вместо куб, умножать на квадрат PLSSS
daniil062: там, где A[i] := A[i] * A[i] * A[i]; оставляешь только две A[i] после приравнивания, т.е. заменяешь на A[i] := A[i] * A[i];
Новые вопросы