Информатика, вопрос задал Оля7865431 , 8 лет назад

СРОЧНО. Помогите. Нужно составить программу к решению задачи: "Дано число n. Перевернуть число".

Ответы на вопрос

Ответил ManyGames
0
var
  n, res, m: longint;
  s: string;

begin
  readln(n);
  while n <> 0 do
  begin
    m := n mod 10;
    s := s + (m.ToString);
    n := n div 10;
  end;
  res := s.ToInteger;
  writeln(res);
end.
Ответил Оля7865431
0
(m.ToString), s.ToInteger, longint, (res) - не встречались нам, не проходили.
Ответил ManyGames
0
x.ToString - преобразует число x в строковый тип данных (string); x.ToInteger - преобразует строку x в соответствующее число. longint - тип данных, подобный integer, но хранит в себе значения от -2147483648..2147483647 (просто вместо него напиши integer), res - это просто ПЕРЕМЕННАЯ, ничего такого. Это как a и b. Writeln(res) выводит его на экран. Да, это всё в справке можно найти.
Ответил ManyGames
0
Если остались ещё вопросы, то в лс.
Ответил petyaGavrikov
0
var
  n, m: longint;
begin
  m:=0;
  readln(n);
  while n > 0 do 
  begin
    m := m*10 + n mod 10;
    n := n div 10;
  end;
  writeln(m);
end.

Пример:
13804
40831
Новые вопросы