СРОЧНО!!! Помогите написать программу языком С++ ДАЮ 100 БАЛОВ!!
Задано целочисленный массив (матрица) А размерности 5х5. Массив А инициализировать элементами в тексте программы при его описании (заполнить произвольно - 5 строк по 5 чисел). В массиве А найти указанные в варианте задачи величины и вывести результат в виде сообщения на консоль, выведя предварительно массив в виде таблицы. Образовать новый массив В, согласно указаниям соответствующего варианта, образованный массив вывести на консоль.
ЗАДАЧА: В массиве А найти разницу средних значений отдельно взятых положительных и отрицательное элементов. Массив В образовать из массива А, заменив в нем все элементы меньше -5 на противоположные.
ЗА ПРАВИЛЬНУЮ ПОМОЩЬ ОТДАМ ВСЕ БАЛЫ И ВЫБЕРУ ЛУЧШИЙ ОТВЕТ! ЗАРАНЕЕ СПАСИБО!)
Ответы на вопрос
Ответ:
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
int a[5][5] =
{
{4,-5,8,-3,1},
{-3,8,-1,1,-8},
{9,6,6,-3,-7},
{-7,-3,3,6,-7},
{7,-3,-6,5,0},
};
int b[5][5];
int i, j, cp, cm, sp, sm;
setlocale(LC_ALL, "Russian");
cout << "Массив A";
for (i = 0; i < 5; i++) {
cout << endl;
for (j = 0; j < 5; j++) {
cout << setw (4) << a[i][j];
}
}
cp = cm = sp = sm = 0;
for (i = 0; i < 5; i++) {
for (j = 0; j < 5; j++) {
if (a[i][j] >= -5)
b[i][j] = a[i][j];
else
b[i][j] = - a[i][j];
if (a[i][j] > 0) {
cp++;
sp += a[i][j];
}
if (a[i][j] < 0) {
cm++;
sm += a[i][j];
}
}
}
cout << endl << endl;
cout << "Среднее значение положительных элементов = " << (float) sp / cp << endl;
cout << "Среднее значение отрицательных элементов = " << (float) sm / cm << endl << endl;
cout << "Массив B";
for (i = 0; i < 5; i++) {
cout << endl;
for (j = 0; j < 5; j++) {
cout << setw(4) << b[i][j];
}
}
return 0;
}
{
int muss[5] = { -5, -6, -7, -8, -9 };
int i;
int muss2[5];
for (i = 0; i < 5; i++) {
if (muss[i] < -5)
muss2[i] = -muss[i];
else
muss2[i] = muss[i];
}
for (i = 0; i < 5; i++)
cout << muss2[i] << " ";
system("pause");
return 0;
}
#include
using namespace std;
int main()
{
int muss[] = { -5, -6, -7, -8, -9 };
int res, res1, res2, res3, res4;
int muss2[] = { res, res1, res2, res3, res4 };
if (muss[0] < -5) res = muss[0] * -1;
if (muss[0] < -5) res1 = muss[1] * -1;
if (muss[0] < -5) res2 = muss[2] * -1;
if (muss[0] < -5) res3 = muss[3] * -1;
if (muss[0] < -5) res4 = muss[4] * -1;
cout << muss2[0] << " ";
system("pause");
return 0;
}