Информатика, вопрос задал Zoudalan , 10 лет назад

Срочно! Помогите! Написать программу в турбо паскале

 Заполнить массив из 10 элементов случайными числами в интервале от 0 до 4 и определить, есть ли в нем одинаковые соседние элементы.

   Пример:

   Исходный массив:

   4  0  1  2  0  1  3  1  1  0

Заранее огромное спасибо!!!!

 

 

 

 

Ответы на вопрос

Ответил sansanic
0

var 

  a: array [1..10] of integer;  //Массив из 10 целочисленных элементов

  i: integer;

begin

  write('Исходный массив: ');

  for i:= 1 to 10 do  {Заполняем массив случайными числами от 0 до 4 и печатаем его}

  begin

    a[i]:= random(4);

    write(a[i], '  ');

  end;

  writeln;  //Перевод на новую строку

  write('Одинаковые соседние элементы:  ');

  for i:= 1 to 9 do  //Печатаем одинаковые соседние элементы

    if a[i] = a[i + 1] then write('a[', i, '] = a[', i + 1, '],  ');

  writeln;  {Перевод на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

end. 

Новые вопросы