Информатика, вопрос задал fenty17 , 2 года назад

Срочно! Помогите написать программу на языке С#. Дан массив размером nxm, элементы которого целые числа. Подсчитать среднее арифметическое четных элементов, расположенных ниже главной диагонали.


ProgRamms: интересная задача...
ProgRamms: хотя
ProgRamms: тупо на повторения базавого синтаксиса C#.
ProgRamms: базового. и повторение
fenty17: а как подсчитать среднее арифметическое нечетных элементов, расположенных выше главной диагонали?
fenty17: ой, ниже главной диагонали
ProgRamms: аналогично, толко в проверке на четность сделать остаток == 1
fenty17: у меня с прошлой задачи, выходит ошибка, пишет, что sum не существует в текущем контексте, а nowSum присвоено значение, но оно ни разу не использовано
ProgRamms: тогда возможно вы запускаете либо не ту прогу, либо просто плохо скопировали, либо плохой компилятор
fenty17: понятно, спасибо вам большое

Ответы на вопрос

Ответил ProgRamms
1

Ответ:

на локальных тестах работает

Объяснение:

using System;

class Program

{

   static int P(string p)

   {

       int a = 0, dec = 1;

       for (int i = p.Length - 1; i >= 0; i--)

       {

           a += (p[i] - '0') * dec;

           dec *= 10;

       }

       return a;

   }

   static void Main(string[] args)

   {

       int n = int.Parse(Console.ReadLine());

       int m = int.Parse(Console.ReadLine());

       int c = 0, sum = 0;

       for (int i = 0; i < n; i++)

       {

           int nowSum = 0;

           string a = Console.ReadLine();

           string[] now = a.Split(' ');

           for (int j = 0; j < i; j++)

           {

               int num = P(now[j]);

               if (num % 2 == 0)

               {

                   c++;

                   sum += num;

               }

           }

       }

       Console.WriteLine(sum / c);

       Console.ReadLine();

   }

}

Новые вопросы