Информатика, вопрос задал gali4ka2360 , 1 год назад

СРОЧНО ПОМОГИТЕ !!
Написать программу для задачи: Дано трехзначное число. Определить, какая из его цифр больше: первая, вторая или последняя. Вывести на экран большую из этих трех цифр.
программа IDLE shell ​

Ответы на вопрос

Ответил p15
1

Ответ:

n=input('введите число: ')

m='0'

for i in range(len(n)):

   if n[i]>m:

       im=i

       m=n[i]

print(f'самая большая цифра {m} стоит на {im+1} месте')

Объяснение:

программе все равно на сколько длинное число.

Сравниваются символы, а не цифры, но ответ верен.

Работает также для чисел вида 345.3948758478

И для не десятичных 34AF454 или 3564a77f094 или 00000100

Важно только чтобы буквы были в одном регистре (можно и это решить)

Новые вопросы