Информатика, вопрос задал Archie3000 , 1 год назад

срочно ПИТОН!!!!!!!!!!!!!!!!!!

Входные данные
На вход программы поступает сначала число N (1<=N<=100), а затем N пар чисел. Первое число каждой пары – натуральное, не превышающее 30000. Второе число каждой пары – 0 или 1.

Выходные данные
Требуется найти пары, в которых второе число равно 1, а из всех таких пар выбрать ту, в которой первое число максимально (если таких пар несколько, выберите любую из них).

Программа должна вывести номер выбранной пары. Если пар, у которых второе число равно 1, нет, то выведите -1.

Примеры
входные данные
3
30000 1
2 1
3 1
выходные данные
300
1 0
входные данные
4
25 1
70 1
100 0
3 1
выходные данные
235
0 1
5

Ответы на вопрос

Ответил lingvini2013
4

n = int(input())

number_max = 0

pair_order = -1

for iteration in range(1, n + 1):

   a, b = list(map(int, input().split()))

   if b == 1:

       if a > number_max:

           number_max = a

           pair_order = iteration

print(pair_order)

Новые вопросы