Информатика, вопрос задал Archie3000 , 1 год назад

Срочно!!!! Питон!!!!
Реализуйте алгоритм бинарного поиска.

Входные данные
В первой строке входных данных содержатся натуральные числа N и K (0NK100000). Во второй строке задаются N элементов первого массива, отсортированного по возрастанию, а в третьей строке – K элементов второго массива. Элементы обоих массивов - целые числа, каждое из которых по модулю не превосходит 109

Выходные данные
Требуется для каждого из K чисел вывести в отдельную строку "YES", если это число встречается в первом массиве, и "NO" в противном случае.

Примеры
входные данные
10 5
1 2 3 4 5 6 7 8 9 10
-2 0 4 9 12
выходные данные
NO
NO
YES
YES
NO

Ответы на вопрос

Ответил stepan7s
10

Ответ:

arr1 = []

n, k = map(int, input().split())

for i in range(n):

  inp = int(input())

  arr1.append(inp1)

for y in range(k):

  if y in arr1:

     print("YES")

  else:

     print("NO")

Объяснение:

Новые вопросы