Информатика, вопрос задал konstantinosakov , 6 лет назад

СРОЧНО ПИТОН!!!!!!!!!!!!!!
Некоторое число n удваивается каждую секунду, выведите весь процесс удвоения в течении t секунд, с учетом первоначального значения.

Формат входных данных
Даны два целые числа n (−1000≤n≤1000), и t (0≤t≤100).

Формат выходных данных
Вывести процесс изменения числа n за t секунд в формате, указанном в примере.

входные данные выходные данные
-100
20
-100
-200
-400
-800
-1600
-3200
-6400
-12800
-25600
-51200
-102400
-204800
-409600
-819200
-1638400
-3276800
-6553600
-13107200
-26214400
-52428800
-104857600
7
10
7
14
28
56
112
224
448
896
1792
3584
7168

Ответы на вопрос

Ответил iambelyashh
1

Ответ:

n = int(input())

num_of_rep = int(input())

print(n)

for i in range(1, num_of_rep+1):

   n = n*2

   print(n)

Новые вопросы