Информатика, вопрос задал darnekrasovaaa , 2 года назад

СРОЧНО!!!! ПИТОН и С++ Количество обменов
Определите, сколько обменов сделает алгоритм пузырьковой сортировки по возрастанию для данного массива.

Входные данные

На первой строке дано число N(1≤N≤1000) — количество элементов в массиве. На второй строке — сам массив. Гарантируется, что все элементы массива различны и не превышают по модулю 109.

Выходные данные

Выведите одно число — количество обменов пузырьковой сортировки.

Примеры
Ввод
Вывод
5
1 2 3 4 5
0
5
5 4 3 2 1
10

Ответы на вопрос

Ответил gegor56
7

Ответ:

c=int(input())

a=input().split()

for i in range(c):

 a[i]=int(a[i])

m=0

unordered=True

while c>1 and unordered:

 unordered=False

 for j in range(c-1):

   if a[j]>a[j+1]:

     a[j],a[j+1]=a[j+1],a[j]

     unordered=True

     m+=1

 c-=1

print(m)

На плюсах не напишу но хоть что-то.

Объяснение:

Проверено сириусом, сам писал не копировал(зуб даю).

Новые вопросы