Информатика, вопрос задал Darina2703 , 7 лет назад

СРОЧНО ПАСКАЛЬ
Написать программу
Задачи на строки
Даны две произвольные строчки. Совпадают ли они побуквенно?

Ответы на вопрос

Ответил kornickevg
0

Ответ:

program sovpadenie_strok;

uses crt;

var

s1,s2:string;

i:integer;

f:boolean;

begin

read(s1);

read(s2);

if (length(s1)=length(s2))then

begin

i:=1;

f:=false;

while(i<length(s1))and(f=false)

do

begin

if s1[i]<>s2[i] then f:=true;

i:=i+1

end;

if f=true then

write('Строки побуквенно не совпадают')

else

write('Строки побуквенно совпадают')

end

else

write('Строки разной длины')

end.

Новые вопросы