Информатика, вопрос задал 145212 , 7 лет назад

Срочно!!!!!!
Pascal ABC Net
a) составьте программу, выводящую на экран числа от 1 до 10, а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
б) Составьте программу, выводящую на экран все числа от - 10 до 10,а также их модули
-10 10
-9 9

Ответы на вопрос

Ответил ismeral
0

Ответ:

1) Program l1;

Var a:integer;

Begin

For a:= 1 to 10 do Writeln(a, ' ', a*a,' ',a*a*a);

end.

2) Program l2;

Var a,b: integer;

Begin

For a:= -10 to 10 do

begin

b:=Abs(a);

Writeln(a, ' ' ,b);

end;

end.

Я не проверял работает ли , но по идее должно

Ответил BobbyFresnel
0
Нет, не будет. Я тоже не проверял Ваше решение, но ABC не будет распознано точно
Ответил BobbyFresnel
0
Abs - это модуль и в математике, и в любом языке, и в любом прикладном пакете. Так что акцент на Паскале излишен.
Ответил kordonom
0
Бобби, помоги пожалуйста и мне: https://znanija.com/task/34226103
Ответил BobbyFresnel
0

===== PascalABC.NET =====

=1=

begin

 for var a := 1 to 10 do

   Println(a, a * a, a * a * a)

end.

=2=

begin

 for var a := -10 to 10 do

   Println(a, Abs(a))

end.

Приложения:
Ответил BobbyFresnel
0
Я удивляюсь: приложены скрины, из которых все видно - и Вы задаете такой вопрос. Отвечаю: и Write ТОЖЕ.
Новые вопросы