Срочно! очень надо!
напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел
Ответы на вопрос
Ответил Аноним
0
function gcd(a,b: longint): longint;
{ Нахождение НОД }
var
i: longint;
begin
while b <> 0 do
begin
a := a mod b;
i := b; b := a; a := i
end;
gcd := a
end;
function lcm(a,b:longint):longint;
{ Нахождение НОК }
begin
lcm:=a*b div gcd(a,b)
end;
begin
Writeln('НОД(36;54;18;15)=',lcm(36,lcm(54,lcm(18,15))))
end.
Результат выполнения программы:
НОД(36;54;18;15)=540
{ Нахождение НОД }
var
i: longint;
begin
while b <> 0 do
begin
a := a mod b;
i := b; b := a; a := i
end;
gcd := a
end;
function lcm(a,b:longint):longint;
{ Нахождение НОК }
begin
lcm:=a*b div gcd(a,b)
end;
begin
Writeln('НОД(36;54;18;15)=',lcm(36,lcm(54,lcm(18,15))))
end.
Результат выполнения программы:
НОД(36;54;18;15)=540
Новые вопросы