Информатика, вопрос задал Красотка1618 , 7 лет назад

СРОЧНО!!! Нужно составить программу к этим заданием!!! 50БАЛЛОВ

Приложения:

Ответы на вопрос

Ответил daniilkey
0

Условие не полностью видно, но насколько я понял, начальные значения элементов массива равны 1..10. Вот программа, которая выводит 7 элемент после обработки массива.


var i,b:integer;

a:array[1..10] of integer=(1,2,3,4,5,6,7,8,9,10);

begin

for i:=1 to 10 do a[i]:=i*i;

b:=a[10];

for i:=0 to 8 do a[10-i]:=a[9-i]; a[i]:=b;

writeln(a[7]); //выводим значение седьмого элемента

end.


Новые вопросы