Информатика, вопрос задал kumiho9fox , 1 год назад

Срочно нужна помощь!
Надо написать программу на си (с функцией main)
• Создайте рекурсивную функцию, которая возвращает факториал числа,
заданного в качестве параметра a.
• Если аргумент недопустим, функция должна вернуть 0.
• Переполнения не должны обрабатываться, возврат функции будет
неопределенным.
• Вот как это должны быть прототипировано:
int ft_recursive_factorial(int nb);​

Ответы на вопрос

Ответил flash77779
1

#include <stdio.h>

int ft_recursive_factorial(int nb)

{

   if (nb < 0)

       return (0);

   if (nb == 0)

       return (1);

   return (nb * ft_recursive_factorial(nb - 1));

}

int main(void)

{

   printf("%d", ft_recursive_factorial(5));

   return (0);

}

Приложения:

kumiho9fox: спасибо большое!
flash77779: Тебе тоже
flash77779: :-)
flash77779: Успехов
Новые вопросы