Информатика, вопрос задал brawlstarsitsl , 1 год назад

! СРОЧНО !
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет суммы и среднего арифмитического введённых положительных чисел. Используйте оператор WHILE.

Ответы на вопрос

Ответил levchencow
0

s = 0

arr = []

while True:

   n = int(input())

   if n == 0:

       break

   if n > 0:

       arr.append(n)

   

print(sum(arr))

print(sum(arr)/len(arr))


brawlstarsitsl: Спасибо большое, но я забыл написать, что нужно на PascalABC...((
Ответил chelodojmolovek12
0

Вот пример программы на Python, реализующей описанную задачу

sum = 0

count = 0

num = int(input("Введите число: "))

while num != 0:

   if num > 0:

       sum += num

       count += 1

   num = int(input("Введите число: "))

if count > 0:

   average = sum / count

   print("Сумма положительных чисел:", sum)

   print("Среднее арифметическое положительных чисел:", average)

else:

   print("Вы не ввели положительных чисел.")

Объяснение:

Программа запрашивает у пользователя целые числа до тех пор, пока не будет введен ноль. Если введенное число положительное, оно добавляется к общей сумме и увеличивается счетчик положительных чисел. После окончания ввода чисел программа проверяет, были ли введены положительные числа (если счетчик больше нуля), и если да, выводит на экран сумму и среднее арифметическое. Если положительных чисел не было, программа выводит соответствующее сообщение.

Лучший ответ пж))


brawlstarsitsl: Спасибо большое, но я забыл про то, что нужно на Pascal ABC написать. Если напишешь на нем - поставлю лучший ответ)
Новые вопросы