Информатика, вопрос задал Павел73 , 2 года назад

Срочно!!!
Напишите программу, которая вводит натуральные числа A и N и вычисляет A^N.
( С использованием цикла (если это вообще применимо)).

Ответы на вопрос

Ответил KingRing7
1
function Power(x,y:real):real;
begin
  if x=0 then
    Power:=0
  else
    if x>0 then
      Power:=exp(ln(x)*y)
    else
      Power:=-exp(ln(abs(x))*y);
end;
 
var
 x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.

Новые вопросы