Информатика, вопрос задал musskotuk52719 , 2 года назад

СРОЧНО!
Напишите программу,которая определяет длину ведённой строки и подсчитывает количество букв «а»


fsdfsd1974: Какой язык программирования
musskotuk52719: Не написано..но какие есть варианты?
fsdfsd1974: На паскале можно

Ответы на вопрос

Ответил fsdfsd1974
5

Если паскаль абс

program v1;

var st1:string;

   i,L:Integer;

   numA:Integer;

begin

   write('text: ');

   readln(st1);

   L := Length(st1);

   numA := 0;

   for i:=1 to L do begin

       case st1[i] of

           'А','а': numA:=numA+1; //rus

           'A','a': numA:=numA+1; //eng

       end;

   end;

   st1 := UpperCase(st1);

   writeln('Dlina stroki ',L);

   writeln('kol-vo A  ',numA);

end.

Приложения:

musskotuk52719: В любом случае спасибо!
fsdfsd1974: Удачи
Новые вопросы