Срочно! Написать в Pascal ABC
Дано N чисел. Найти самое большое число, на которое делятся все N чисел.
Входные данные
В первой строке дано число N. Во второй строке даны через пробел N чисел (1 <= N <= 1000).
Выходные данные
Выведите искомое число
Ответы на вопрос
Ответил Аноним
0
var a: array of integer;
i, n, x, digit: integer;
b1, b2: boolean;
begin
readln(n);
setlength(a, n);
for i := 0 to n - 1 do readln(a[i]);
b1 := true;
x := 1;
digit := x;
while b1 do begin
if b2 then digit := x;
inc(x);
b2 := true;
for i := 0 to n - 1 do begin
if (abs(a[i]) < x) and (a[i] <> 0) then begin b1 := false;break; end
else if a[i] mod x <> 0 then begin b2 := false;break; end
end;
end;
write(digit);
end.
i, n, x, digit: integer;
b1, b2: boolean;
begin
readln(n);
setlength(a, n);
for i := 0 to n - 1 do readln(a[i]);
b1 := true;
x := 1;
digit := x;
while b1 do begin
if b2 then digit := x;
inc(x);
b2 := true;
for i := 0 to n - 1 do begin
if (abs(a[i]) < x) and (a[i] <> 0) then begin b1 := false;break; end
else if a[i] mod x <> 0 then begin b2 := false;break; end
end;
end;
write(digit);
end.
Ответил estroganova
0
А можно, пожалуйста, надо более простом языке; с циклом for, repeat, until и так далее. А то мы этого просто не прохрдили
Ответил estroganova
0
проходили*
Новые вопросы
Математика,
2 года назад
Английский язык,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад