Информатика, вопрос задал niknety , 10 лет назад

Срочно!!! написать программу в паскаль.
Дан массив целых чисел, состоящий из 20 элементов. Заполнить его датчиком случайных чисел. Заменить максимальный элемент на противоположный по знаку.

Ответы на вопрос

Ответил kage1998
0
program chik;
const n=20;
var a:array[1..20]of integer;
i,l,max:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(100)-50;
max:=a[1];
for i:=2 to n do
if(a[i]>max)then max:=a[i];
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=-max;
write(a[i],' ');
end;
end.
Новые вопросы