СРОЧНО
написать программу, которая для введенного двузначного числа А определяет, являются ли цифры, из которых оно состоит, четными или нет. если обе цифры четные, то тогда требуется найти их сумму и вывести её на экран. Если первая четная, а вторая нет, то тогда надо найти их произведение и вывести его на экран. Если первая нечетная, а вторая четная, то тогда требуется найти их частное и вывести его на экран. Если же обе цифры нечетные, то просто необходимо сообщить об этом.
Ответы на вопрос
Ответил Puz1koO
0
var
a:integer;
begin
readln(a);
case a div 10 mod 2 of
0: case a mod 10 mod 2 of
0: writeln('Sum:', a div 10 + a mod 10);
1: writeln('Pr:', a div 10 * a mod 10)
end;
1: case a mod 10 mod 2 of
0: writeln('Chast:', (a div 10)/(a mod 10));
1: writeln('Oba nechet')
end;
end;
end.
Новые вопросы