Информатика, вопрос задал kramarenkopolina724 , 2 года назад

Срочно на языке python
Напишите программу, которая получает с клавиатуры два числа, одно из которых может не быть целым, и вычисляет их произведение, используя только операции сложения. Учтите, что числа могут быть отрицательными

Ответы на вопрос

Ответил vintt
1

Ответ:

x=int(input())

y=int(input())

res=0

z=0

while z!=(abs(y)):

   res=res+(abs(x))

   z=z+1

if y < 0:

   res= -res

if x < 0:

   res= -res

print(res)

p.s.Если помог с решением, отметь решение, как лучшее, заранее спасибо.


Аноним: одно из чисел может быть не целым
vintt: понял, забыл про это условие
Аноним: бывает )))
Ответил Аноним
0

Ответ:

a = int(input('целое число '))

b = float(input('не целое число '))

a_b = 0

for i in range(abs(a)):

   a_b += abs(b)

if (a < 0 and b < 0) or (a > 0 and b > 0):

   print(a_b)

else:

   print(-a_b)

Объяснение:

Новые вопросы