Информатика, вопрос задал arportnow , 7 лет назад

сРОЧНО !!!! НА С++, НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅109
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
Вывод
14 21
42

Ответы на вопрос

Ответил kostyazhmur03
1

Ответ:

#include <iostream>

#include <math.h>

using namespace std;

int main()

{

int n=0;

int a,b;

cout << "Введите a b" << endl;

cin >> a;

cin >> b;

bool bl ;

bl = true;

while ( bl==true){

n++;

if ((n%a== 0) &&(n%b == 0))

bl = false;

}

cout << "НОК = "<< n << endl;

system("pause");

return 0;

}

Новые вопросы