Информатика, вопрос задал superkiki , 8 лет назад

СРОЧНО!МНОГО БАЛЛОВ!!Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4.
INPUT 3,24,25,54
RESULT2

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(ReadlnInteger)
      .Where(t->(t mod 6=0) and (t mod 10=4)).Count.Println
end.
Ответил superkiki
0
подскажите,а если надо на с++?
Ответил Аноним
0
Подсказываю: требуемый язык надо указывать в вопросе, не надеясь на телепатию.
Ответил superkiki
0
да,уже поняла свою ошибку,но все же..
Ответил Аноним
0
Что - "все же"? Ваша ошибка - это труд других людей в мусорное ведро. Свой-то жаль было бы, поди...
Ответил clinteastwood2
0
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    size_t size, value, count; 
    cin >> size;
    vector<int> v;
    for (size_t i = 0; i < size; ++i) { 
        cin >> value; 
        v.push_back(value); 
    }
    count = count_if(v.cbegin(), v.cend(), [](const int& i) { return (i % 6 == 0) | (i
% 10 == 4); });
    cout << count;
}
Ответил clinteastwood2
0
Спасибо не забывайте говорить
Новые вопросы