СРОЧНО МНОГО БАЛЛОВ Написать программу которая вычисляет сумму нечётных цифр в записи данного натурального числа
Ответы на вопрос
Ответил Nata9911
0
Язык C++.
#include <iostream>
using namespace std;
int main () {
int a, n, sum = 0;
cout << "Введите число: " << endl;
cin >> a;
while (a > 0){
n = a%10;
if(n%2 != 0){
sum += n;
}
a/= 10;
}
cout << sum;
}
#include <iostream>
using namespace std;
int main () {
int a, n, sum = 0;
cout << "Введите число: " << endl;
cin >> a;
while (a > 0){
n = a%10;
if(n%2 != 0){
sum += n;
}
a/= 10;
}
cout << sum;
}
Новые вопросы