Информатика, вопрос задал lidiakuhar61 , 6 лет назад

Срочно!К данной системе уравнения нужно написать программу

Приложения:

ivanovgrisa881: Python?
lidiakuhar61: Да, Помогите пожалуйста

Ответы на вопрос

Ответил ivanovgrisa881
1

Python

1 вариант:

x=int(input())

if x>0:

   f=x+5

if x<0:

   f=x*3

if x==0:

   f=15

print(f)

2 вариант:

x=int(input())

def F(x):

   if x>0:

       return x+5

   if x<0:

       return x*3

   if x==0:

       return 15

print(F(x))

* int принимает только целые числа. Для дробей необходимо использовать float.

Если есть вопросы - пишите)

Приложения:

lidiakuhar61: А что если в ответе нечего не выводится?
ivanovgrisa881: При каком вводе?
lidiakuhar61: В программу ввела код а в ответе пусто
ivanovgrisa881: Какой именно "код"?
lidiakuhar61: Я кажется поняла .Если больше нуля то подставив какое либо число можно получить ответ (7+5=12) так?
ivanovgrisa881: Если вы ввели 7, то да
lidiakuhar61: Спасибо за помощь!
ivanovgrisa881: Всегда пожалуйста)
Новые вопросы