СРОЧНО!! Используя вспомогательные алгоритмы и подпрограммы, задайте в Паскале вычисление наибольшего общего делителя для произвольных входных данных. Входные данные задайте самостоятельно путём ввода с клавиатуры. Для задания 1 постройте блок-схему алгоритма, которая будет иллюстрировать приведённое решение в Паскале.
БЛОК-СХЕМУ ОБЯЗАТЕЛЬНО
я пыталась что-то сделать, это правильно?
Приложения:

Speedyzs:
Это же pascal?
Ответы на вопрос
Ответил Speedyzs
2
program GCD;
var
a, b, c: integer;
procedure CalculateGCD(var a, b: integer);
var
c: integer;
begin
while b <> 0 do
begin
c := a mod b;
a := b;
b := c;
end;
end;
begin
writeln('Enter two numbers: ');
readln(a, b);
CalculateGCD(a, b);
writeln('The greatest common divisor is: ', a);
end.
В этом примере мы определяем CalculateGCD которая берет два целых числа по ссылке и вычисляет их НОД после чего вводим два числа вызываем процедуру CalculateGCD и выводим результат на экран.
Новые вопросы