Срочно! информатика. Перевести на Паскаль и написать программу для решения этого...
Приложения:

Ответы на вопрос
Ответил Olya20182018
0
попробуем
program lll;
var
x,x1:real;
res1,res2,res3,res4:real;
begin
readln(x);
x1:=abs(x);
if (x<0) then
begin
res1:=2*sin(x1)
end
else
if(x>0) then
if(x<=5) then
begin
res2:=sqrt(x);
end;
else
if (x>5)
then if (x<=10) then
res3:=2x*x-sqr(x);
end
else
res4:=cos(2*x)/a;
end;
end.
program lll;
var
x,x1:real;
res1,res2,res3,res4:real;
begin
readln(x);
x1:=abs(x);
if (x<0) then
begin
res1:=2*sin(x1)
end
else
if(x>0) then
if(x<=5) then
begin
res2:=sqrt(x);
end;
else
if (x>5)
then if (x<=10) then
res3:=2x*x-sqr(x);
end
else
res4:=cos(2*x)/a;
end;
end.
Ответил Olya20182018
0
Лучше на С++, структура была бы другой! Получше... Но пока как-то так!
Ответил NameXD
0
Да вот задали на паскале.... Вот сидел и плакал над ним...) пасибо)
Ответил Olya20182018
0
Там проверьте еще точки с запятой... Я быстро писала, может где забыла поставить... бегины и энды сверьте...
Ответил Аноним
0
На С++ школьные задачи всегда ХУЖЕ и замороченнее выглядят.
Ответил Аноним
0
А в решении автор забыл описать переменную a и обеспечить её инициализацию.
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
Вариант 1
begin
var (x,a):=ReadReal2('Введите х и a через пробел:');
var y:real;
if x<=0 then y:=2*Sin(Abs(x))
else
if x<=5 then y:=Sqrt(x)
else
if x<=10 then y:=2*x*x-Sqrt(x)
else y:=Cos(2*x)/a;
Writeln('Y=',y)
end.
Вариант 2
begin
var (x,a):=ReadReal2('Введите х и a через пробел:');
Writeln('Y=',
x<=0 ? 2*Sin(Abs(x)) :
x<=5 ? Sqrt(x) :
x<=10 ? 2*x*x-Sqrt(x) : Cos(2*x)/a)
end.
Примеры
Введите х и a через пробел: 12.4 -3
Y=-0.315050171382724
Введите х и a через пробел: 5.8 1.156
Y=64.8716810842415
// Внимание! Если программа не работает, обновите версию!
Вариант 1
begin
var (x,a):=ReadReal2('Введите х и a через пробел:');
var y:real;
if x<=0 then y:=2*Sin(Abs(x))
else
if x<=5 then y:=Sqrt(x)
else
if x<=10 then y:=2*x*x-Sqrt(x)
else y:=Cos(2*x)/a;
Writeln('Y=',y)
end.
Вариант 2
begin
var (x,a):=ReadReal2('Введите х и a через пробел:');
Writeln('Y=',
x<=0 ? 2*Sin(Abs(x)) :
x<=5 ? Sqrt(x) :
x<=10 ? 2*x*x-Sqrt(x) : Cos(2*x)/a)
end.
Примеры
Введите х и a через пробел: 12.4 -3
Y=-0.315050171382724
Введите х и a через пробел: 5.8 1.156
Y=64.8716810842415
Ответил Аноним
0
Ну как, все еще осталась мысль, что на С++ "лучше" ? )))
Новые вопросы
Литература,
2 года назад
Алгебра,
8 лет назад
Геометрия,
8 лет назад
Математика,
9 лет назад
Обществознание,
9 лет назад