Информатика, вопрос задал GemingRush , 7 лет назад

Срочно хелп
Надо составить программу которая из ряда чисел выводит числа кратные 3 в паскаль

Ответы на вопрос

Ответил sendi2007
0

Ответ:program chisla;

var i:integer;

begin

for i:=1 to 100 do

begin

if (i mod 3 = 0)

then write(i,' ');

end;

Объяснение:

Ответил BobbyFresnel
0
А с чего Вы вдруг решили, что "ряд чисел" - это последовательность натуральных от 1 до 100?
Ответил KnowsUser1
0

Ответ:

PascalABC.NET

begin

 var (lb, rb) := ReadInteger2('введите начало и конец ряда чисел');

 Range(lb, rb).Where(x->x mod 3 = 0).Println;

end.

Или, если ряд - это что то, вводимое с клавиатуры:

begin

 ReadSeqInteger('Вводи: ', ReadInteger('Длина последовательности:')).Where(x -> x mod 3 = 0).Println;

end.

Новые вопросы