Информатика, вопрос задал lohovloh600 , 7 лет назад

СРОЧНО!!! ДЛЯ Python 3!!!
Площадь треугольника
Напишите программу, которая вычисляет площадь треугольника по методу Герона. Используйте функция round(), чтобы округлить ответ до 5 знака после точки.

Вводные данные: на первой строке дано число N, количество треугольников. Затем на N строках стороны треугольников написанные через пробел.

Выходные данные: для каждого треугольника на N строках значение площади, которое округленно до 5 знака после точки. Используйте функцию для вычисления площади для каждого треугольника.

Ввод:
4
10 19 17
13 11 15
20 20 16
10 12 11

Вывод должен быть таким:
84.71127
69.62893
146.64242
51.52123

Ответы на вопрос

Ответил Omikami
0

from math import sqrt

n = int(input())

output = []

for i in range(n):

   x = [int(k) for k in  input().split()]

   p = sum(x)/2

   output.append(round(sqrt(p*(p-x[0])*(p-x[1])*(p-x[2])), 5))

for i in output:

   print(i)

Новые вопросы